Instalando Ocomon com o Xampp no Windows 7

Esta semana um amigo, me pediu que auxiliasse referente á instalação do Sistema Ocomon, pois bem, abaixo irei comentar algumas informações para a instalação, logicamente a customização do sistema fica ao seu critério.

OcoMon é uma ferramenta (FREE-Licença GPL) para efetuar a abertura, controle e acompanhamento de chamados técnicos, de forma on-line. Ele possui relatórios, aplicativo de inventário de hardware e software integrados, bem como informações sobre as ocorrências registradas. É ideal para técnicos e operadores do Help Desk.

Nesse primeiro post mostrarei como instalar o ocomon em um ambiente com Windows 7.
Escolhi o Xampp para ser meu servidor, atualmente está na versão 1.7.3. Para ir para o endereço de Download clique Aqui

Após efetuarem o download executem o Xampp.

Escolher o caminho desejado, eu aconselho deixar na raiz do C mesmo, clicar em Instalar e aguardar o processo, essa é a parte mais demorada da instalação.
Após irá abrir a seguinte tela:
Deixe com Y se desejar que seja criado um atalho na área de trabalho, caso nao deseje tecle n e após tecle Enter.
Nessa nova tela tecle Enter. A mesagem avisa que ira mudar os caminhos do Xampp para o diretorio correto.
Após teclar Enter uma nova tela irá aparecer.
Deixe o padrão n e tecle Enter.
Irá aparecer mais duas telas do prompt tecle Enter nas duas.
Após irá abrir a última tela de instalação.
Deixe a opção com x e tecle enter.
Após realizada a instalação abra o ícone do Xampp e clique em Start para os serviços de Apache e MySQL
Os serviços tem que ficar com o status Running.
Vamos testar a instalação do Xampp.
Vá em Iniciar – Executar
Irá abrir uma página do Xampp escolha Português Brasil
Assim terminamos a instalação do Xampp.
Agora vamos para a instalação do Ocomon.
Baixe a versao 2.0RC6 Clicando Aqui
Após conclusão do download descompacte no seguinte local:
C:\Xampp\htdocs
Renomeie a pasta descompactada para o nome de sua preferencia, no meu caso optei por deixar somente com o nome Ocomon.
Lembrando que esse caminho se deu pois na hora da instalação do Xampp escolhi instalar na raiz do C.
Agorá vá em:
C:\Xampp\htdocs\ocomon\includes
Localize o arquivo config.inc.php-dist renomeie-o deixando somente como config.inc.php
Finalizado essa etapa vamos importar o banco de dados do Ocomon para o MySQL.
Vá em: Iniciar – Executar
Digite http://localhost/xampp e tecle enter.
Na tela do Xampp no seu canto esquerdo clique em phpMy Admin

Nessa nova tela clique em Importar

Clique em Procurar e localize o arquivo DB_OCOMON_2.0RC6_FULL, o caminho dele éC:\xampp\htdocs\ocomon\install\2.0RC6
Clique em executar e aguarde a conclusão.
Ao finalizar aparecerá ao lado esquerdo um novo banco de dados chamado Ocomon_RC6
Assim está finalizada a instalação do Ocomon, para testar vá em: Iniciar – Executar
Lembrando que ocomon pois o nome da pasta onde esta a aplicacao é ocomon.
O usuário padrão é admin senha admin
ATUALIZAÇÃO – 14/05/2014
Devido alguns problemas encontrados no momento de importar o arquivo *.SQL no banco de dados MySQL, estou disponibilizando um novo arquivo com a mesma finalidade, sanando alguns problemas encontramos por alguns. Segue link abaixo.
O script SQL cria usuário e dá permissão de acesso ao banco de dados do Ocomon, a senha deste usuário dentro do script é: ocomon123.
Documentação de como configurar o ocomon acessar a Wiki do Ocomon.
ATUALIZAÇÃO – 13/09/2016
Pessoal,
Projeto Ocomon foi muito bom, porém encontra-se totalmente de descontinuado, recomendação Project GLPI excelente.

37 pensamentos sobre “Instalando Ocomon com o Xampp no Windows 7

  1. Primeiramente parabens pelo tutorial, muito bom!

    instalei tudo certinho porém na hora de importar a base de dados de um erro.

  2. deu erro na importação, cara, tô irado com esse ocomon, não consigo importar nem por pra rodar…

    Técnico: Não logado | Logon |

    Usuário:
    Senha:

    Cadastro para abertura de chamados? Clique aqui!
    OcoMon – Monitor de Ocorrências e Inventário de equipamentos de informática.
    Versão: 2.0-RC6 – Licença GPL

    Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\ocomon\includes\include_geral.inc.php on line 47

    Notice: Undefined index: sis_screen in C:\xampp\htdocs\ocomon\includes\common\login.php on line 188

    Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\ocomon\includes\common\login.php on line 219
    NÃO FOI POSSÍVEL ACESSAR A TABELA DE CONFIGURAÇÕES DO SISTEMA!

  3. Olá amigo,

    Executei todos os passos corretamente e ao chegar na importação da o erro abaixo:

    Erro
    Comando SQL:

    CREATE TABLE `config` ( `conf_cod` INT( 4 ) NOT NULL AUTO_INCREMENT PRIMARY KEY , `conf_sql_user` VARCHAR( 20 ) NOT NULL DEFAULT ‘ocomon’, `conf_sql_passwd` VARCHAR( 50 ) NULL , `conf_sql_server` VARCHAR( 40 ) NOT NULL DEFAULT ‘localhost’, `conf_sql_db` VARCHAR( 40 ) NOT NULL DEFAULT ‘ocomon’, `conf_db_ccusto` VARCHAR( 40 ) NOT NULL DEFAULT ‘ocomon’, `conf_tb_ccusto` VARCHAR( 40 ) NOT NULL DEFAULT ‘CCUSTO’, `conf_ccusto_id` VARCHAR( 20 ) NOT NULL DEFAULT ‘codigo’, `conf_ccusto_desc` VARCHAR( 20 ) NOT NULL DEFAULT ‘descricao’, `conf_ccusto_cod` VARCHAR( 20 ) NOT NULL DEFAULT ‘codccusto’, `conf_ocomon_site` VARCHAR( 50 ) NOT NULL DEFAULT ‘http://localhost/ocomon/’, `conf_inst_terceira` INT( 4 ) NOT NULL DEFAULT ‘-1’, `conf_log_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/logs/’, `conf_logo_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/logos’, `conf_icons_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/icons/’, `conf_help_icon` VARCHAR( 50 ) NOT[…]

    Mensagens do MySQL :

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘TYPE = MYISAM COMMENT = ‘Tabela de configurações diversas do sistema” at line 24

    O que pode ser?

      • Bom dia Kelsen Lima,

        Eu deixo no padrão que o PhpAdmin informa.

        Deveria alterar?

        Usei o Xammp e deu certo, mas tenho preferência pelo PhpAdmin.

  4. ow amigo, tentei com todas as compatibilidades e n executou a importação do arquivo de instalação, será q é a versão do xampp?? estou usando a 1.83

    • Aew consegui instalar esta versão, antes de executar a importação do arquivo DB_OCOMON_2.0RC6_FULL temos que abrir ele com bloco de notas e substituir todas as palavras TYPE por ENGINE, e depois sim fazer a importação. Quem encontrou esse erro deve antes de importar o novo arquivo, deletar a tabela ocomon_rc6 ou se não souber fazer isso reinstalar o xampp, bem, aqui eu segui esses passos e consegui rodar direitinho, procura tbm por uma atualização no site que eu tinha feito a descompactação dela na pasta mas n sei se isso afeta, vlew aí pela dica ^^

      • Continua apresentando erro…

        Erro
        Comando SQL:

        CREATE TABLE `config` ( `conf_cod` INT( 4 ) NOT NULL AUTO_INCREMENT PRIMARY KEY , `conf_sql_user` VARCHAR( 20 ) NOT NULL DEFAULT ‘ocomon’, `conf_sql_passwd` VARCHAR( 50 ) NULL , `conf_sql_server` VARCHAR( 40 ) NOT NULL DEFAULT ‘localhost’, `conf_sql_db` VARCHAR( 40 ) NOT NULL DEFAULT ‘ocomon’, `conf_db_ccusto` VARCHAR( 40 ) NOT NULL DEFAULT ‘ocomon’, `conf_tb_ccusto` VARCHAR( 40 ) NOT NULL DEFAULT ‘CCUSTO’, `conf_ccusto_id` VARCHAR( 20 ) NOT NULL DEFAULT ‘codigo’, `conf_ccusto_desc` VARCHAR( 20 ) NOT NULL DEFAULT ‘descricao’, `conf_ccusto_cod` VARCHAR( 20 ) NOT NULL DEFAULT ‘codccusto’, `conf_ocomon_site` VARCHAR( 50 ) NOT NULL DEFAULT ‘http://localhost/ocomon/’, `conf_inst_terceira` INT( 4 ) NOT NULL DEFAULT ‘-1’, `conf_log_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/logs/’, `conf_logo_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/logos’, `conf_icons_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/icons/’, `conf_help_icon` VARCHAR( 50 ) NOT[…]

        Mensagens do MySQL : Documentação

        #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘TYPE = MYISAM COMMENT = ‘Tabela de configurações diversas do sistema” at line 24

  5. este e o erro

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user ‘ocomon’@’localhost’ (using password: YES) in C:\xampp\htdocs\ocomon\includes\classes\conecta.class.php on line 54
    Access denied for user ‘ocomon’@’localhost’ (using password: YES)

    • Isso está ocorrendo devido usuário “ocomon” não ter permissão no banco, vamos fazer o seguinte crie o banco manualmente e edite o script mysql, retire estas sintaxe.

      CREATE DATABASE /*!32312 IF NOT EXISTS*/`ocomon_rc6` /*!40100 DEFAULT CHARACTER SET utf8 */;

      CREATE USER ‘ocomon’@’localhost’ IDENTIFIED BY ‘senha_ocomon_mysql’;
      GRANT SELECT , INSERT , UPDATE , DELETE ON `ocomon_rc6` . * TO ‘ocomon’@’localhost’;

      USE `ocomon_rc6`;

      Salve e rode somente com as estruturas para baixo.

      — Estrutura da tabela `CCUSTO`

      CREATE TABLE `CCUSTO` (
      `codigo` int(4) NOT NULL auto_increment,
      `codccusto` varchar(6) NOT NULL default ”,
      `descricao` varchar(25) NOT NULL default ”,
      PRIMARY KEY (`codigo`),
      KEY `codccusto` (`codccusto`)
      ) COMMENT=’Tabela de Centros de Custo’;

  6. Anteriormente troquei todas as palavras de Type para Engine e deu esse erro:

    Erro
    Comando SQL:

    CREATE USER ‘ocomon’@’localhost’ IDENTIFIED BY ‘senha_ocomon_mysql’;

    Mensagens do MySQL : Documentação

    #1396 – Operation CREATE USER failed for ‘ocomon’@’localhost’

    Kelsen, fiz o que vc falou acima e deu esse erro aqui:

    Erro
    Comando SQL:

    CREATE TABLE `CCUSTO` (

    `codigo` INT( 4 ) NOT NULL AUTO_INCREMENT ,
    `codccusto` VARCHAR( 6 ) NOT NULL DEFAULT”,
    `descricao` VARCHAR( 25 ) NOT NULL DEFAULT”,
    PRIMARY KEY ( `codigo` ) ,
    KEY `codccusto` ( `codccusto` )
    ) COMMENT = ’Tabela de Centros de Custo’;

    Mensagens do MySQL : Documentação

    #1046 – No database selected

  7. Rapaziada… para quem está com problemas na Importação da base de dados vai uma dica. Fiz isso e resolveu meu problema.

    No campo “Configurar o Mapa de Caracteres do ficheiro: utf-8” eu coloquei Win1252 e importei normalmente!

    Espero ter ajudado alguém e não atrapalhado ninguém!

    • Leonardo,

      Qual erro está ocorrendo? Até qual parte você conseguiu ir?
      Se for somente na hora de carregar banco de dados, existe um script novo no link do Mega.

  8. Na verdade quando rodo da o erro acima de usuario Ocomon nao ter previlegio para acessar o BD. onde acho o script meu caro? agradeço a força

  9. Bom Dia,

    Quando estou rodando o ocomon esta aparecendo esta mensagem.
    quando troco para o mysqli nada funciona.

    Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\wamp\www\Ocomon\ocomon_2.0-RC6\includes\classes\conecta.class.php on line 54

    alguém já passou por problema semelhante ?

  10. Bom dia..

    ao abrir o ocomon..

    aparece o seguinte texto no topo da pagina…

    e ao colocar o login admin e senha admin
    aparecem as seguintes mensages:

    Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\Ocomon\includes\include_geral.inc.php on line 47

    Notice: Undefined index: sis_screen in C:\xampp\htdocs\Ocomon\includes\common\login.php on line 188

    Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\Ocomon\includes\common\login.php on line 219
    NÃO FOI POSSÍVEL ACESSAR A TABELA DE CONFIGURAÇÕES DO SISTEMA!

    já tentei tudo o que foi comentado acima e nada… preciso de um help.. pois meu tcc depende disso!! rsrsRS

  11. me ajudem seguinte erro

    #1044 – Access denied for user ‘hcelso’@’localhost’ to database ‘ocomon_rc6’

  12. Olá, utilizei o novo script e ao terminar de importar e depois executar, aparece o seguinte erro:

    Erro
    Comando SQL:

    CREATE USER ‘ocomon’@’localhost’ IDENTIFIED BY ‘ocomon123’;
    Mensagens do MySQL : Documentação

    #1396 – Operation CREATE USER failed for ‘ocomon’@’localhost’

  13. Quando eu fiz o processo de importar gerou o seguinte erro:
    Comando SQL:

    CREATE USER ‘ocomon’@’localhost’ IDENTIFIED BY ‘senha_ocomon_mysql’;

    Mensagens do MySQL : Documentação
    #1396 – Operation CREATE USER failed for ‘ocomon’@’localhost’

    Porém apareceu o banco ocomon_rc6, ao executar ele gera o seguinte erro:
    Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\ocomon\index.php on line 52

    e não sai os acentos.

    • esse caso é fácil de resolver é ir no php.ini e na linha onde timezone e fazer essa modificação abaixo:
      date.timezone = Etc/GMT+4
      como estou no MS utilizo essa configuração, mais outros lugares do pais muda conforme o seu fusorario

  14. Alguém está tendo esse erro?

    Erro

    Parece haver um erro na sua consulta SQL. A mensagem de erro do servidor MySQL abaixo, isto se existir alguma, também o poderá ajudar a diagnosticar o problema.
    ERROR: Pontuação desconhecida @ 74
    STR: /;
    SQL: !40101 SET NAMES utf8 */;!40101 SET NAMES utf8 */;!40101 SET NAMES utf8 */;

    Comando SQL:

    !40101 SET NAMES utf8 */;

    Mensagens do MySQL : Documentação
    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘!40101 SET NAMES utf8 */’ at line 1

  15. Erro
    consulta SQL:

    CREATE TABLE `config` ( `conf_cod` INT( 4 ) NOT NULL AUTO_INCREMENT PRIMARY KEY , `conf_sql_user` VARCHAR( 20 ) NOT NULL DEFAULT ‘ocomon’, `conf_sql_passwd` VARCHAR( 50 ) NULL , `conf_sql_server` VARCHAR( 40 ) NOT NULL DEFAULT ‘localhost’, `conf_sql_db` VARCHAR( 40 ) NOT NULL DEFAULT ‘ocomon’, `conf_db_ccusto` VARCHAR( 40 ) NOT NULL DEFAULT ‘ocomon’, `conf_tb_ccusto` VARCHAR( 40 ) NOT NULL DEFAULT ‘CCUSTO’, `conf_ccusto_id` VARCHAR( 20 ) NOT NULL DEFAULT ‘codigo’, `conf_ccusto_desc` VARCHAR( 20 ) NOT NULL DEFAULT ‘descricao’, `conf_ccusto_cod` VARCHAR( 20 ) NOT NULL DEFAULT ‘codccusto’, `conf_ocomon_site` VARCHAR( 50 ) NOT NULL DEFAULT ‘http://localhost/ocomon/’, `conf_inst_terceira` INT( 4 ) NOT NULL DEFAULT ‘-1’, `conf_log_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/logs/’, `conf_logo_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/logos’, `conf_icons_path` VARCHAR( 50 ) NOT NULL DEFAULT ‘../../includes/icons/’, `conf_help_icon` VARCHAR( 50 ) NOT[…]

    Alguém pode ajudar?

  16. Resolvi os erros do SQL, resolvi o problema da criação do usuário, gerei o banco normalmente, só que na hora de chamar o aplicativo via browser, me retorna o ERROR 404 : Objeto não encontrado. O que pode estar acontecendo? Obrigado!

  17. Erro
    Parece haver um erro na sua consulta SQL. A mensagem de erro do servidor MySQL abaixo, isto se existir alguma, também o poderá ajudar a diagnosticar o problema.

    ERROR: Pontuação desconhecida @ 74
    STR: /;
    SQL: !40101 SET NAMES utf8 */;!40101 SET NAMES utf8 */;!40101 SET NAMES utf8 */;

    Comando SQL:

    !40101 SET NAMES utf8 */;

    Mensagens do MySQL : Documentação

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘!40101 SET NAMES utf8 */’ at line 1

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s